SNMP access problem (SNMP-dead)

makis

05-05-2004 13:54:36

Sorry to make a nuisance of myself, but I've tried about everything that I can thnk of and still cannot get netmrg-gatherer() to read from snmpd().

I can snmpwalk() the entire system MIB but netmrg-gatherer() can't even get the sysUpTime.0. eg

[code1234dd55aab]
$/usr/local/bin/netmrg-gatherer -c1023 -l1023
....
[Dev: 0002] karaduen / 192.168.22.1
[Dev: 0002] Starting SNMP Session.
[Dev: 0002] SNMPv2c
[Dev: 0002] Port: 161; Timeout: 1000000; Retries: 3.
Locking SNMP
Unlocking SNMP
[Dev: 0002] SNMP Query ('192.168.22.1', 'public', 'system.sysUpTime.0')
[Dev: 0002] SNMP Uptime is 0
[Dev: 0002] Device is SNMP-dead. Avoiding SNMP tests.
....
[/code1234dd55aab]

Whereas
[code1234dd55aab]
$ snmpwalk -v2c -c public 192.168.22.1 system.sysUpTime.0
sysUpTime.0 534960
[/code1234dd55aab]
My /etc/snmp/snmpd.conf is reduced to
[code1234dd55aab]
rocommunity public
rwcommunity public

com2sec local 127.0.0.1 public
com2sec lan 192.168.22.0/24 public
com2sec public default public

group public v1 public
group public v2c public

view systemview included .1
access public "" any noauth exact systemview none none
[/code1234dd55aab]

As you can see, to avoid complications, I've called [b234dd55aab]everything[/b234dd55aab] "public". I've switched the devices back and forth between snmp v.1 and v.2. .... still no joy...

I'm using net-snmp 5.0.9, could there be some kind of incompatibility between this and the UCD versions?