NET-SNMP on Fedora Core 2

balleman

24-05-2004 17:46:58

I recently upgraded my desktop from FC1 to FC2, and now my snmpd will sit and eat 100% of cpu-time constantly. Anyone experience this, or have a solution?

silfreed

24-05-2004 21:12:59

No clue. Have you strace'd the daemon yet to see where the tight-loop is?
I think Net-SNMP 5.1.1 might have some other bugs; I have a bug open with Red Hat about the pass-through support in it, but it appears to be in the tarball as well.

-Doug

balleman

24-05-2004 21:24:17

Ok, I found it.

In [bd07c2ee092]/etc/rc.d/init.d/snmpd[/bd07c2ee092] there was
[code1d07c2ee092]OPTIONS="-Lsd v/null -p /var/run/snmpd -a -c /etc/snmp/snmpd.conf"[/code1d07c2ee092]

The [bd07c2ee092]-L[/bd07c2ee092] options are for logging, and they're conflicting apparently. I removed the /dev/null one and kept the syslog one.

[code1d07c2ee092]OPTIONS="-Lsd -p /var/run/snmpd -c -a /etc/snmp/snmpd.conf"[/code1d07c2ee092]

Seems to be fine now.

balleman

25-05-2004 19:02:08

Well, it's not fine. At some point during troubleshooting I must've deleted my snmpd.conf. I realized that today, created a new one, and it's happening again.