SNMP Problems Was (Can't get Trango 5830S AP to show data)

wjw

10-09-2004 10:49:15

Okay, I have latency working on this AP, which I assume means that RRDtool and logging are working right... problem is the Ethernet Graphs show 0.

The results from 'netmrg-gatherer -sm' show

[quote0ba3696c33]etMRG starting.
Creating Lockfile.
Initializing SNMP library.
Initializing RRDTOOL pipe.
[ACTIVE] Last 0, Now 0
[Dev 0004] Starting device thread.
[Dev 0004] MySQL connection established.
[Dev 0004] Hawea AP / <Field Omitted>
[Dev 0004] Not checking SNMP uptime as per configuration.
[Dev 0005] Starting device thread.
[Dev 0005] MySQL connection established.
[Dev 0008] Starting device thread.
[Dev 0008] MySQL connection established.
[Dev 0004] This option should only be used as a last resort.
[Dev 0005] Christchurch Router / <Field Omitted>
[Dev 0008] WNK_SUID5 / <Field Omitted>
[Dev 0008] [Sub 0015] Starting Subdevice.
[Dev 0004] Number of Interfaces is 0
[Dev 0004] [Sub 0014] Starting Subdevice.
[Dev 0004] [Sub 0014] [Mon 0036] Starting Monitor.
[Dev 0004] [Sub 0014] [Mon 0036] Sending '/usr/local/libexec/netmrg/ping_time.pl 10.10.10.211' to shell.
[Dev 0005] SNMP Uptime is 0
[Dev 0005] Device is SNMP-dead. Avoiding SNMP tests.
[Dev 0005] Trimming device event log.
[Dev 0005] Ending device thread.
Thread Ended.
[Dev 0008] [Sub 0015] [Mon 0037] Starting Monitor.
[Dev 0008] [Sub 0015] [Mon 0037] Sending '/usr/local/libexec/netmrg/ping_time.pl 10.10.10.5' to shell.
[Dev 0004] [Sub 0014] [Mon 0036] Value 8.080

[Dev 0004] [Sub 0014] [Mon 0036] Value is non-integer.
[Dev 0004] [Sub 0014] [Mon 0033] Starting Monitor.
[Dev 0008] [Sub 0015] [Mon 0037] Value 6.982

[Dev 0008] [Sub 0015] [Mon 0037] Value is non-integer.
[Dev 0004] [Sub 0014] [Mon 0033] Value .1.3.6.1.4.1.5454.1.20.1.15.5.0 2224000988
[Dev 0004] [Sub 0014] [Mon 0033] Value is non-integer.
[Dev 0004] [Sub 0014] [Mon 0032] Starting Monitor.
[Dev 0008] Trimming device event log.
[Dev 0008] Ending device thread.
Thread Ended.
[PASSIVE] Last 0, Now 1
[Dev 0004] [Sub 0014] [Mon 0032] Value .1.3.6.1.4.1.5454.1.20.1.15.6.0 1337314549
[Dev 0004] [Sub 0014] [Mon 0032] Value is non-integer.
[Dev 0004] Trimming device event log.
[Dev 0004] Ending device thread.
Thread Ended.
[PASSIVE] Last 1, Now 0
Closed MySQL connection.
Runtime 1
Closed RRDTOOL pipe.
Cleaned up SNMP.[/quote0ba3696c33]

But the graphs for the two values, show 0... I'm stumped... any ideas?

Thanks,


Bill

silfreed

10-09-2004 16:59:35

It looks like your AP is returning the string ' .1.3.6.1.4.1.5454.1.20.1.15.5.0 2224000988'. Without knowing more about the AP or having access to the MIB, it's impossible for us to know how it's supposed to be monitored.
I know I have a Linksys AP that supports SNMP, but none of the standard IF-MIB items. If your AP is like this, you'll have to see if anybody has written any conversion scripts and are available on the internet.

-Doug

wjw

10-09-2004 22:24:00

ok cool, I'll see what I can do, will let you know the results as I get them ;)

They work in MRTG... so will start from there...

I have the mib's so will search through the forums and work out how to add those in....

wjw

11-09-2004 01:28:21

okay I now have the mib's loaded and get the following

[code1a73659f781][root@radius etc]# snmpwalk -O v -v1 -c public 10.10.10.211 .1.3.6.1.4.1.5454.1.20.1.15.5.0
525664079
[root@radius etc]#

[/code1a73659f781]

For the moment I've written a script to get the values I need, if anyone has any better ideas, please let me know.

[code1a73659f781]#!/usr/bin/perl

# Return trango oids



($ip) = @ARGV[0];
($interface) = @ARGV[1];
($direction) = @ARGV[2];

if ($interface eq "Eth0")
{
if ($direction eq "In")
{
$SNMPOID = ".1.3.6.1.4.1.5454.1.20.1.15.5.0";
}
if ($direction eq "Out")
{
$SNMPOID = ".1.3.6.1.4.1.5454.1.20.1.15.6.0";
}
}
if ($interface eq "RF0")
{
if ($direction eq "In")
{
$SNMPOID = ".1.3.6.1.4.1.5454.1.20.1.15.7";
}
if ($direction eq "Out")
{
$SNMPOID = ".1.3.6.1.4.1.5454.1.20.1.15.8";
}
}
if ($interface eq "Temp")
{
$SNMPOID = ".1.3.6.1.4.1.5454.1.20.1.16";
}
$result = `snmpwalk -O v -v1 -c public $ip $SNMPOID`;
# $result = $result[$#result];
print($result);[/code1a73659f781]

wjw

11-09-2004 03:52:04

I've just tried one of my cisco routers, measing the cpu and get the same thing as above

[Dev 0005] [Sub 0017] Starting Subdevice.
[Dev 0005] [Sub 0017] [Mon 0038] Starting Monitor.
[Dev 0005] [Sub 0017] [Mon 0038] Value .1.3.6.1.4.1.9.2.1.58.0 5
[Dev 0005] [Sub 0017] [Mon 0038] Value is non-integer.

silfreed

11-09-2004 10:28:34

How are you setting up your monitors? Are you setting them up as scripts and passing the OID as the parameter?
Most SNMP tests should only return a value, not the OID as the value.

-Doug

wjw

11-09-2004 21:04:18

Using the Built-In Cisco CPU SNMP Test (Cisco - CPU Utilization .1.3.6.1.4.1.9.2.1.58.0), I'm not sending any parameters to the SNMP test but I still get
[code1ff8b8d69a9]
[Dev: 0005] [Sub: 0017] Starting Subdevice.
[Dev: 0005] [Sub: 0017] [Mon: 0038] Starting Monitor.
[Dev: 0005] [Sub: 0017] [Mon: 0038] Value: .1.3.6.1.4.1.9.2.1.58.0 7
[Dev: 0005] [Sub: 0017] [Mon: 0038] Value is non-integer.
[/code1ff8b8d69a9]
It's giving me the OID and the CPU usage.

My own test scripts as shown above are working fine
[code1ff8b8d69a9]
[Dev: 0010] [Sub: 0022] [Mon: 0051] Starting Monitor.
[Dev: 0010] [Sub: 0022] [Mon: 0051] Sending '/usr/local/libexec/netmrg/Link10MU.pl 10.10.10.240 Eth0 Out' to shell.
[Dev: 0010] [Sub: 0022] [Mon: 0051] Value: 3850787042
[/code1ff8b8d69a9]
Its when I use the SNMP tests that things dont work. No matter what I do I get the OID back in the value.

TIA,

Bill

balleman

12-09-2004 11:59:52

It looks like a problem with NetMRG's interfacing to your snmp-libraries. What version of net-snmp are you using? What distro are you using?

wjw

12-09-2004 18:42:47

okay I'm running

Mandrake 10.0
Net-SNMP 5.1.2

I compiled Net-SNMP with Perl support to enable me to add mibs...

wjw

14-09-2004 07:05:24

I have just upgraded to 0.17 but I still get the same result (

silfreed

17-09-2004 10:21:59

[quotee8eb90b58a="wjw"]I have just upgraded to 0.17 but I still get the same result ([/quotee8eb90b58a]
Right; We weren't able to address this by this release. We are planning on testing NetSNMP 5.1.2 very soon, we'll try to let you know the results as soon as we have them.

-Doug

wjw

17-09-2004 19:43:50

I'm not a CPP programmer, but I've been fiddling with the source, so if by some miracle I sort it, I'll let you know.

silfreed

18-09-2004 12:05:26

I was able to compile NetMRG with net-snmp 5.1.2 and I didn't experience the problem you're having (the values containing both the oid and result).
Do you have anything in your snmp.conf (not snmp[b395a8ff2aa]d[/b395a8ff2aa].conf) that affects output of snmp* commands?
I just reread your old post that also shows that snmpwalk returned both as well - this could be a global configuration that outputs the oid and the result. I can't find an output modifer that would do this, but maybe you can think of something that might do this.

-Doug

silfreed

18-09-2004 12:16:39

Actually, that snmpwalk line must've wrapped when I was posting, b/c now I see that it doesn't report the oid and result.

What happens when you use mandrake's RPMs? Do you have the same problems?
What configure parameters did you pass to net-snmp when you compiled it?

-Doug

wjw

19-09-2004 01:45:11

What happens when you use mandrake's RPMs?

I haven't tried the Mandrake Net-SNMP RPM's. I will try the RPM's and let you know the result.

Do you have the same problems?

To be Advised.

What configure parameters did you pass to net-snmp when you compiled it?

The only non standard parameters I gave it was " ./configure --with-perl-modules", and that was only after I had the initial problem as I needed the perl module to add my own MIB's.

marros

05-11-2004 10:46:04

I am having the same problem with Mandrake 10.1 with net-snmp-5.1-7mdk (I have another thread going...sorry). Trying snmpwalk with the -O v, shows only the value, but I can't find a setting in snmp.conf to change this globally.

silfreed

05-11-2004 18:53:53

Looks like Mandrake's /etc/snmp/snmp.local.conf file has a line 'quickprinting yes'. If you could try disabling this and let us know how it works, that'd be great. If it works, we'll see what we can do as a more permanent solution instead of this workaround.

-Doug