nothing is being graphed

jlaff

27-09-2004 14:14:35

I followed the tutorial exacly, including the graphing tutorial... For some reason, nothing is being graphed... I cant figure out why nothing at all is being graphed.. please help.. thank you

silfreed

27-09-2004 21:08:36

First step; is netmrg running out of cron? If installed via the RPM, this requires 'service netmrg start', otherwise, make sure netmrg_cron.sh is in /etc/crontab or root's crontab. You can check to make sure it's be executed by looking in /var/log/netmrg/lastrun.log (redhat) or /usr/local/var/log/netmrg/lastrun.log otherwise.

If that's working correctly, what kind of devices are you trying to graph (linux, windows, cisco switches, etc). What aspects of them are you trying to graph?

-Doug

jlaff

28-09-2004 11:29:27

I checked the lastrun.log file and it reads
NetMRG starting.
[Dev 0001] Starting device thread at 2004-09-28 112500.
[Dev 0001] Device is SNMP-dead. Avoiding SNMP tests.
[Dev 0001] [Sub 0002] Interface subdevice has no interface parameters.
[Dev 0001] [Sub 0002] Subdevice aborted due to previous errors.
[Dev 0001] [Sub 0003] Disk subdevice has no disk parameters.
[Dev 0001] [Sub 0003] Subdevice aborted due to previous errors.
[Dev 0001] Ending device thread at 2004-09-28 112504, after a duration of 4 seconds.
Thread Ended.

I dont understand why it says "Device is SNMP-dead" please let me know if reasons why this error is coming up. Thanks a bunch

silfreed

28-09-2004 13:48:28

Well, for disks and interfaces, it's better to go through the 'view interface cache' and 'view disk cache' (you may have to recache first) to graph them; there are parameters that are required so it knows which interface to check (the subdevice name isn't enough).
'SNMP Dead' can be from a number of reasons; incorrect SNMP type (v1 vs v2c), wrong SNMP community string, or the fact that SNMP isn't running. If you're sure it's configured correctly (you can do stuff like 'snmpwalk -v1 -c public localhost system.sysDescr'), then you can edit your device and select the checkbox that says 'disable SNMP uptime check'. This will remove the SNMP test (only use this when necessary; if your box is really down, it drastically increases the time to gather information).

-Doug