I can't see any graphs

pavelfg

24-01-2005 15:56:29

Hi

I've just installed netmrg-0.18.2. I installed all the requirements. Then I followed the whole installation tutorial, step by step. Everything worked fine.
After that, I followed the tutorial, but I can't see any graph, they appear like a crossed-square. (when the browser is unable to display the image)
I've checked the permissions of the crontab, they're correct.

If i started it manually, apparentely it works fine.
I've also checked some messages in this list related to "miising graphs", and they suggest to run the command

/usr/local/bin/netmrg-gatherer -sm

And when I run it, i get this error

/usr/local/bin/netmrg-gatherer error while loading shared libraries libnetsnmp.so.5 cannot open shared object file No such file or directory

But libnetsnmp.so.5 exsists under 2 folders

/usr/local/bin/libnetsnmp.so.5
/usr/local/lib/libnetsnmp.so.5


Finally under /usr/local/var/log/netmrg, I got some errors, evrytime i run this command; and they have the same format



# ll
total 4
-rw-r--r-- 1 netmrg netmrg 145 ene 24 1545 lastrun.err.1106603100
-rw-r--r-- 1 netmrg netmrg 0 ene 24 1545 lastrun.log.1106603100

# vi lastrun.err.1106603100

/usr/local/bin/netmrg-gatherer error while loading shared libraries libnetsnmp.so.5 cannot open shared object file No such file or directory


I think, this is my problem, but where can I setup the path of libnetsnmp.so.5.?????


I hope someone can help me...


Grettings, pavel

silfreed

24-01-2005 19:08:22

Let's start by finding about couple things out about your platform.
What operating system are you running on what hardware?
I take it you've installed net-snmp from source, correct? Did you pass any options to that when you configured it (if you can include your ./configure line, that'd be great!)?
What options did you use to configure netmrg?

-Doug

keb

24-01-2005 22:36:47

In addition to what Doug has asked about, you can also see if libnetsnmp.so.5 is in your shared libraries. You should be able to see the problem by running

[code1d009e01a1c]ldd /path/to/netmrg-gatherer[/code1d009e01a1c]

This will probably show several libraries that the gatherer is linked against. For the netsnmp libraries, you might see something like "libnetsnmp.so.5 => Not Found". This usually means that the netsnmp library isn't part of the shared libraries. The following command can be used on most unix based systems to actually search for a particular shared library.

[code1d009e01a1c]/sbin/ldconfig -p | grep libnetsnmp
...
libnetsnmp.so.5 (libc6) => /usr/lib/libnetsnmp.so.5[/code1d009e01a1c]

Feel free to post the output from both of those commands above (in addition to the info Doug asked for), so that we can get a better picture of how your system is setup.

-Kevin

pavelfg

25-01-2005 10:23:02

Thanks guys for your help.

I installed it in a i386 architecture, with linux fedora3.
My configure line is

./configure --with-rrdtool=/path-to-rrd-tool --with-mysql-lib-dir=/path-to-mysqllib



I ran the commands you told me, and it displays the following


netmrg-0.18.2]# /sbin/ldconfig -p | grep libnetsnmp
libnetsnmptrapd.so.5 (libc6) => /usr/local/lib/libnetsnmptrapd.so.5
libnetsnmptrapd.so (libc6) => /usr/local/lib/libnetsnmptrapd.so
libnetsnmpmibs.so.5 (libc6) => /usr/local/lib/libnetsnmpmibs.so.5
libnetsnmpmibs.so (libc6) => /usr/local/lib/libnetsnmpmibs.so
libnetsnmphelpers.so.5 (libc6) => /usr/local/lib/libnetsnmphelpers.so.5
libnetsnmphelpers.so (libc6) => /usr/local/lib/libnetsnmphelpers.so
libnetsnmpagent.so.5 (libc6) => /usr/local/lib/libnetsnmpagent.so.5
libnetsnmpagent.so (libc6) => /usr/local/lib/libnetsnmpagent.so
libnetsnmp.so.5 (libc6) => /usr/local/bin/libnetsnmp.so.5
libnetsnmp.so.5 (libc6) => /usr/local/lib/libnetsnmp.so.5
libnetsnmp.so (libc6) => /usr/local/lib/libnetsnmp.so


netmrg-0.18.2]# ldd /usr/local/bin/netmrg-gatherer
libnetsnmp.so.5 => /usr/local/bin/libnetsnmp.so.5 (0xb7555000)
libmysqlclient.so.12 => not found
libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0xb747d000)
libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0xb73ca000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0xb73ba000)
libz.so.1 => /usr/lib/libz.so.1 (0xb73ac000)
libdl.so.2 => /lib/libdl.so.2 (0xb73a8000)
libm.so.6 => /lib/tls/libm.so.6 (0xb7386000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb737d000)
libc.so.6 => /lib/tls/libc.so.6 (0xb7246000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0xb75eb000)




pavel

balleman

25-01-2005 17:49:54

Since you're using FC3, is there a reason you didn't use the net-snmp-* RPMs included in FC3, and the NetMRG RPM from our website? If you don't have a particular need, using the RPMs would be a much better option.

keb

28-01-2005 19:55:09

I agree with Brady. The RPMS for FC3 available here would be much easier for you to install.

[quote9f876ff80e="pavelfg"]# /sbin/ldconfig -p | grep libnetsnmp
...
libnetsnmp.so.5 (libc6) => /usr/local/bin/libnetsnmp.so.5
libnetsnmp.so.5 (libc6) => /usr/local/lib/libnetsnmp.so.5
...[/quote9f876ff80e]

I don't think you should have libnetsnmp.so.5 in /usr/local/bin/. The bin/ directories are usually for executable binaries or scripts, not shared libraries. The duplicate entry for libnetsnmp.so.5 shouldn't be causing the problem, but it shouldn't break anything to remove it from that location and rebuild the ldconfig cache (man ldconfig for more info).

[quote9f876ff80e="pavelfg"]# ldd /usr/local/bin/netmrg-gatherer
...
libmysqlclient.so.12 => not found
...[/quote9f876ff80e]

From this output you can see that the libmysqlclient.so.12 library isn't found. What version of MySQL do you have installed, and how did you install it. If you're using the RPM version from mysql.com, you will need to install the MySQL-shared RPM (or the shared-compat one) to get this particular library.

-Kevin

pavelfg

31-01-2005 11:51:07

Thanks guys.

I installed RPM's and everything is ok!!!! )


grettings