Error in mysql...newbee

srinivassin

10-02-2005 10:07:04

Hi, i m newbee to linux and netmrg...as per the installtion document i done everything...but when configureing mysql i got problem. i never ever used mysql before.
i created database netmrg
#mysqladmin create netmrg
after that i entered this command
#mysql -u root -p netmrg < share/netmrg.mysql
i get error msg like this share/netmrg.mysql No such file or directory.
can plz, explain why i get this error...eve i tryied with ; at the end of the command...becuase of this i get this error in browser.

Warning mysql_connect() Access denied for user 'netmrguser@localhost' (Using password YES) in /usr/local/var/www/netmrg/lib/database.php on line 33
DB_ERROR Cannot connect to the database server.

my os centos3-3 (redhat clone0
mysql-server-3.23.58-2.3
plese help me...

keb

10-02-2005 11:08:06

[quote56035ac50e="srinivassin"]#mysql -u root -p netmrg < share/netmrg.mysql
i get error msg like this share/netmrg.mysql No such file or directory.[/quote56035ac50e]

Did you install via RPM or source? Since you're using CentOS and we don't have RPMS built for that, I'll assume from source. In a source install, you can usually find this file at /usr/local/share/netmrg/db/netmrg.mysql

[quote56035ac50e="srinivassin"]Warning mysql_connect() Access denied for user 'netmrguser@localhost' (Using password YES) in /usr/local/var/www/netmrg/lib/database.php on line 33
DB_ERROR Cannot connect to the database server.[/quote56035ac50e]

One of the assumed steps is that users will change/set the password of the netmrg mysql user. You can do this via the mysql command line or via phpMyAdmin. Since you probably haven't set the password yet, you can remove the '-p' option from the mysql command that is failing.

-Kevin

srinivassin

18-02-2005 07:48:07

hi, thank you very muc..its working now...i gave the full root of that file there without password...then its starts working..now...