Nan for value for graphs

d3cypher

08-03-2005 14:00:46

Greetings..

I came across NetMRG from the cacti.net site, so much easier than cacti.

Anyway, did the install, followed the tutorial and everything seems to be fine, except the graphs are not showing any data. I've searched the forums here and have not found _the_ answer, but I can tell you when I run netmrg-gather -sm I get the following

netmrg-gatherer -sm
NetMRG starting.
Creating Lockfile.
Initializing SNMP library.
Initializing RRDTOOL pipe.
[ACTIVE] Last 0, Now 0
[Dev 0002] Starting device thread at 2005-03-08 135141.
[Dev 0002] MySQL connection established.
[Dev 0002] REX-INFOSEC-01 / <Field Omitted>
[Dev 0002] SNMP Uptime is 1 days, 030007 (9763893 centiseconds)
[Dev 0002] Number of Interfaces is 2
[Dev 0002] [Sub 0004] Starting Subdevice.
[Dev 0002] [Sub 0004] [Mon 0020] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0020] Value 572323
[Dev 0002] [Sub 0004] [Mon 0020] Value is an integer.
[Dev 0002] [Sub 0004] [Mon 0019] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0019] Value 3888287
[Dev 0002] [Sub 0004] [Mon 0019] Value is an integer.
[Dev 0002] [Sub 0004] [Mon 0021] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0021] Value 9512
[Dev 0002] [Sub 0004] [Mon 0021] Value is an integer.
[Dev 0002] [Sub 0004] [Mon 0017] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0017] Value 1214708
[Dev 0002] [Sub 0004] [Mon 0017] Value is an integer.
[Dev 0002] [Sub 0004] [Mon 0018] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0018] Value 15124
[Dev 0002] [Sub 0004] [Mon 0018] Value is an integer.
[Dev 0002] [Sub 0004] [Mon 0025] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0025] Value U
[Dev 0002] [Sub 0004] [Mon 0025] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0024] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0024] Value U
[Dev 0002] [Sub 0004] [Mon 0024] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0022] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0022] Value U
[Dev 0002] [Sub 0004] [Mon 0022] Value is not numeric.
[Dev 0002] [Sub 0005] Starting Subdevice.
[Dev 0002] [Sub 0005] [Mon 0026] Starting Monitor.
[Dev 0002] [Sub 0005] [Mon 0026] Value 2365892312
[Dev 0002] [Sub 0005] [Mon 0026] Value is an integer.
[Dev 0002] [Sub 0005] [Mon 0027] Starting Monitor.
[Dev 0002] [Sub 0005] [Mon 0027] Value 2944860618
[Dev 0002] [Sub 0005] [Mon 0027] Value is an integer.
[Dev 0002] [Sub 0006] Starting Subdevice.
[Dev 0002] [Sub 0006] [Mon 0028] Starting Monitor.
[Dev 0002] [Sub 0006] [Mon 0028] Value 34605612
[Dev 0002] [Sub 0006] [Mon 0028] Value is an integer.
[Dev 0002] [Sub 0006] [Mon 0029] Starting Monitor.
[Dev 0002] [Sub 0006] [Mon 0029] Value 38409344
[Dev 0002] [Sub 0006] [Mon 0029] Value is an integer.
[Dev 0002] [Sub 0007] Starting Subdevice.
[Dev 0002] [Sub 0007] [Mon 0030] Starting Monitor.
[Dev 0002] [Sub 0007] [Mon 0030] Value 1304360
[Dev 0002] [Sub 0007] [Mon 0030] Value is an integer.
[Dev 0002] [Sub 0007] [Mon 0031] Starting Monitor.
[Dev 0002] [Sub 0007] [Mon 0031] Value 8264060
[Dev 0002] [Sub 0007] [Mon 0031] Value is an integer.
[Dev 0002] Trimming device event log.
[Dev 0002] Ending device thread at 2005-03-08 135141, after a duration of 0 seconds.
Closed MySQL connection.
Runtime 1
Failed to open runtime file for writing.
Thread Ended.
Closed RRDTOOL pipe.
Cleaned up SNMP.


Now the Failed to open runtime file for writing of course is of concern. I have check the permissions on /var/www/netmrg and they are netmrg.netmrg and 755 for everthing below that htdoc. Is there something I'm missing, I say something about checking the perms where the rrd files are, I don't have any.. But I do have rrdtool installed.

Help is appreciated.

Platform

RH 9.0 - patched (mostly)
rrdtool 1.0.49 (dag rpm)
netmrg 0.18-2.1 (rpm)
mysql 3.23.58 (rpm)
net-snmp 5.0.9 (rpm)



Thanks,

John

silfreed

08-03-2005 15:07:44

[quote8e8ed676dc="d3cypher"]I came across NetMRG from the cacti.net site, so much easier than cacti.[/quote8e8ed676dc]
Thanks!

[quote8e8ed676dc="d3cypher"]Now the Failed to open runtime file for writing of course is of concern. I have check the permissions on /var/www/netmrg and they are netmrg.netmrg and 755 for everthing below that htdoc.[/quote8e8ed676dc]
Actually it's the /var/lib/netmrg/rrd and /var/log/netmrg directories and subfiles that should be owned by netmrg. This is taken care of by the RPM, but if you run netmrg-gatherer by hand as root once, the files get owned by it and can't get converted back.

See if that fixes anything, then get back to us. I did notice some 'U's in the netmrg-gatherer output - that might be the source of your NaNs.

-Doug