no information/graphs about available RAM and SWAP

mofog

20-06-2005 07:59:18

Hi,

finally I got all the other graphs working on my SuSE Linux 9.1 server, but the graphs for RAM and SWAP always stay empty.

It seems that netmrg doesn't get the necessary data from the snmpd. I have to say, that the documentation is not very helpful
concering graphs for network interfaces or disks - but maybe I overlooked something again and again ;-).

What I did is

Create a new Group.
Create a new Device-Group.
Create a new Device (my Server).
I added a Group called "System" and added the Templates
Linux Box - Available Memory, CPU Utilization, Load Average, Logged In Users, System Processes, TCP Connections".

All of these Graphs work now, except the ones for RAM and swap.

After some hours of "googeling"-around I found out, how to display the available and used disk-space on specific partitions (you have to add something like "disk /" to /etc/snmpd.conf, right?).

And also the Interfaces eth0, eth1 and ppp0 are working well
(you have to manually add them via "Groups"... add "Interface" and put in the right parameters ("ifDescr" with "eth0" and so on). Is this right, too?).

But the memory and swap-problem still exists.

Can anybody help me?

Thanks

silfreed

20-06-2005 10:16:08

Unfortunately there are just some versions of net-snmp that don't report these values correctly. I would suggest looking for an update from Suse to see if it fixes this problem.

-Doug

mofog

21-06-2005 15:24:32

Thank you very much!

The update to version 5.1.3 pre 1 solved this problem.
The RAM and SWAP values are correctly displayed now.
But another one is not working anymore ;-(.
I don't get any data about the current CPU Processes.

Do you have one more answer for me -)?

Thanks!

silfreed

21-06-2005 15:35:57

By "CPU Processes" do you mean System Processes or Load Average?
Either of these, we've never had problems getting them to display. The problem with the memory graphs was the kernel jump from 2.4 to 2.6 when the interfaces changed for gathering the info and net-snmp didn't keep up. I'm not sure why those others would break.

-Doug

mofog

21-06-2005 16:33:41

Sorry, I meant "System Processes".
It keeps constantly a value of 0.0, but it worked before I switched to the newer snmp-Version.

As the (now working) graph "Available Memory" does not make much sense (it permanently shows that 350 MB SWAP are used and 3.75 MB of RAM are free), I'm thinking about re-installing the old snmp-Version shipped with SuSE 9.1.

But if you have any further ideas about how to solve this,
let me know, I'll try them!

By the way NetMRG is the first monitoring-solution I've found on the net, which is easy to install, (relatively) easy configurable and has an appealing interface. Well done!