Data is not getting graphed

ankush

11-02-2006 05:52:13

hey friends,

I have installed netmrg through rpm on CentOS 4.0 ,configured mysql database for it and also set the cron job.

I am monitoring one of my Linux Server (Fedora Core3) but the problem I am facing is that the graph is there but there is no data like

Disk Available (KB) Vaule 0
Rate of Change 0

This value is coming for every monitor and only the timestamp is getting changed.

The output of netmrg-gatherer -sm is

Creating Lockfile.
Initializing SNMP library.
Initializing RRDTOOL pipe.
[ACTIVE] Last 0, Now 0
[Dev 0002] Starting device thread at 2006-02-11 160653.
[Dev 0003] Starting device thread at 2006-02-11 160653.
[Dev 0002] MySQL connection established.
[Dev 0003] MySQL connection established.
[Dev 0002] Mail Server / <Field Omitted>
[Dev 0003] server1 / <Field Omitted>
[Dev 0002] SNMP Uptime is 6 days, 110046 (56078485 centiseconds)
[Dev 0002] Number of Interfaces is 0
[Dev 0002] [Sub 0004] Starting Subdevice.
[Dev 0002] [Sub 0004] [Mon 0017] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0017] Value U
[Dev 0002] [Sub 0004] [Mon 0017] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0018] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0018] Value U
[Dev 0002] [Sub 0004] [Mon 0018] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0019] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0019] Value U
[Dev 0002] [Sub 0004] [Mon 0019] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0020] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0020] Value U
[Dev 0002] [Sub 0004] [Mon 0020] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0021] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0021] Value U
[Dev 0002] [Sub 0004] [Mon 0021] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0022] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0022] Value U
[Dev 0002] [Sub 0004] [Mon 0022] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0023] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0023] Value U
[Dev 0002] [Sub 0004] [Mon 0023] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0024] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0024] Value U
[Dev 0002] [Sub 0004] [Mon 0024] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0025] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0025] Value U
[Dev 0002] [Sub 0004] [Mon 0025] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0026] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0026] Value U
[Dev 0002] [Sub 0004] [Mon 0026] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0028] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0028] Value U
[Dev 0002] [Sub 0004] [Mon 0028] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0029] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0029] Value U
[Dev 0002] [Sub 0004] [Mon 0029] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0030] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0030] Value U
[Dev 0002] [Sub 0004] [Mon 0030] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0031] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0031] Value U
[Dev 0002] [Sub 0004] [Mon 0031] Value is not numeric.
[Dev 0002] [Sub 0004] [Mon 0032] Starting Monitor.
[Dev 0002] [Sub 0004] [Mon 0032] Value U
[Dev 0002] [Sub 0004] [Mon 0032] Value is not numeric.
[Dev 0002] Trimming device event log.
[Dev 0002] Ending device thread at 2006-02-11 160653, after a duration of 0 seconds.
Thread Ended.
[Dev 0003] SNMP Uptime is Zilch (0 centiseconds)
[Dev 0003] Device is SNMP-dead. Avoiding SNMP tests.
[Dev 0003] Trimming device event log.
[Dev 0003] Ending device thread at 2006-02-11 160657, after a duration of 4 seconds.
Thread Ended.
[PASSIVE] Last 0, Now 0
Closed MySQL connection.
Runtime 4
Closed RRDTOOL pipe.
Cleaned up SNMP.

In monitoring group the Availability shows "SNMP Uptime 6 days,1159.33".

I have followed the example given in the manual for monitoring.
http//wiki.netmrg.net/wiki/Basic_Tutorial

I have given "public" as community string for SNMP and I have choosen snmpv1.

Please let me know if you need any further inputs.

Thanks & Regards

Ankush Grover

silfreed

15-02-2006 08:43:34

What OS do you have installed on your mail server? If linux, what SNMP version?

-Doug