No graph displaying

spoofiz

14-03-2006 10:09:20

Hi all,
I've just installed netmrg on my linux station (FC4, with php5...), I followed the tutorial, I also check the forum but I've found nothing to solve my problem...

I do have change the netmrg.xml file with the right Database setup and the right rrdtool path ... but still have a broken image when clicking to display a graph ..
(I've also another rrdtool tool called cacti on my linux station and it all works fine).

Thanks for answer ...

Bye

balleman

14-03-2006 12:29:14

Hello,

I just added a page to the manual to help you determine why your graphs are not rendering http//wiki.netmrg.net/wiki/Debug_Graph_Rendering.

Please let us know if this doesn't help you resolve your problem.

spoofiz

15-03-2006 04:13:39

Hey, Thanks for the answer ...

Here is what i get with debug -->
[code19ec3d3d33b]
/usr/local/rrdtool/bin/rrdtool graph - -s -108000 -e -360 --title "%dev_name% - Load Average" -w 575 -h 100 -b 1000 -v "run queue size" --imgformat PNG DEF:zero=/usr/local/var/lib/netmrg/rrd/zero.rrd:mon_25:AVERAGE DEF:data1=/usr/local/var/lib/netmrg/rrd/mon_22.rrd:mon_22:AVERAGE DEF:data1l=/usr/local/var/lib/netmrg/rrd/mon_22.rrd:mon_22:LAST DEF:data1m=/usr/local/var/lib/netmrg/rrd/mon_22.rrd:mon_22:MAX AREA:data1#FF9900:"1 Minute " GPRINT:data1l:LAST:"Current\:%8.2lf %s" GPRINT:data1:AVERAGE:"Average\:%8.2lf %s" GPRINT:data1m:MAX:"Maximum\:%8.2lf %s" COMMENT:"\n" DEF:data2=/usr/local/var/lib/netmrg/rrd/mon_23.rrd:mon_23:AVERAGE DEF:data2l=/usr/local/var/lib/netmrg/rrd/mon_23.rrd:mon_23:LAST DEF:data2m=/usr/local/var/lib/netmrg/rrd/mon_23.rrd:mon_23:MAX LINE2:data2#330066:"5 Minute " GPRINT:data2l:LAST:"Current\:%8.2lf %s" GPRINT:data2:AVERAGE:"Average\:%8.2lf %s" GPRINT:data2m:MAX:"Maximum\:%8.2lf %s" COMMENT:"\n" DEF:data3=/usr/local/var/lib/netmrg/rrd/mon_24.rrd:mon_24:AVERAGE DEF:data3l=/usr/local/var/lib/netmrg/rrd/mon_24.rrd:mon_24:LAST DEF:data3m=/usr/local/var/lib/netmrg/rrd/mon_24.rrd:mon_24:MAX LINE2:data3#990000:"15 Minute" GPRINT:data3l:LAST:"Current\:%8.2lf %s" GPRINT:data3:AVERAGE:"Average\:%8.2lf %s" GPRINT:data3m:MAX:"Maximum\:%8.2lf %s" COMMENT:"\n" VRULE:1142463600#F00000

Script execution debug information:
Marker Time Diff
Start 1142502455.88117100 -
before headers 1142502455.88127200 0.000101
before auth 1142502455.88140900 0.000137
after auth 1142502455.88397200 0.002563
before get command 1142502455.88406400 9.2E-05
after get command 1142502455.89739700 0.013333
before exec command 1142502455.89749800 0.000101
after exec command 1142502455.92100700 0.023509
Stop 1142502455.92114900 0.000142
Start to Stop 0.039978[/code19ec3d3d33b]

So, I did what is written in the Debug_graph_rendering page and i get this error

[b9ec3d3d33b]ERROR opening '/usr/local/var/lib/netmrg/rrd/mon_19.rrd' No such file or directory[/b9ec3d3d33b]

Indeed there is only zero.rdd in this folder.

--------------------> EDIT
I've got something else actually, after [b9ec3d3d33b]# ./netmrg-gatherer -sm[/b9ec3d3d33b]

NetMRG starting.
Creating Lockfile.
Initializing SNMP library.
Initializing RRDTOOL pipe.
MySQL Connection Failure. (Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2))
Critical Master database connection failed.
Closed RRDTOOL pipe.
Cleaned up SNMP.
-------------------------/

Any advice would be great, thanks.

spoofiz

16-03-2006 05:50:47

[quoteb1e9b74f1a="spoofiz"]
MySQL Connection Failure. (Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2))
Critical Master database connection failed.[/quoteb1e9b74f1a]

+
Can I change the path to mysql.sock or something ?

balleman

08-04-2006 18:25:50

You can override the default MySQL socket. In the netmrg.xml file, change the "socket" statement under "database".