The term sub-device has been used ever since the NetMRG 0.79 era of old (prior to the 0.10 series public releases). I've never really been happy with it, and there has been a bit of grief about the term's akwardness on this forum as well. At this point it might be quite painful to change the term throughout the code, but it would probably be worth it to make things less confusing.
Suggestions for a replacement?
I think "Component" might be OK. Covers disks and interfaces nicely, not quite so well for "system" and other global/grouping sub-devices.
If you have a suggestion, please post!
I think another thing we should think about more globally is the fact that we're planning on getting rid of the Interface and Disk sub-device-types and replacing them with some generic indexing system. I'm not sure if that might change how someone thinks about naming.
Still, I think "Component" might cover things pretty well - even for "System" groupings. The "System component" doesn't sound [i84f8b54a41]bad[/i84f8b54a41], anyway.